Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13313 closed Bug (wontfix)

When I paste text from PDF document, only partial text appears in the editor

Reported by: sushil Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Hi Team,

I had a PDF file which contains a table. When I paste the content directly into the CKEditor it only gets the text till the table. Rest of the text below table is not displayed. Also entering the text after the table becomes difficult.

Attachments (1)

Sample.pdf (29.0 KB) - added by sushil 4 years ago.
Sample PDF containing table and text

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by sushil

Attachment: Sample.pdf added

Sample PDF containing table and text

comment:1 Changed 4 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.4.7

PDF passes no data to CKEditor that allows turning it into clipboard. This is a "won't fix" issue.

comment:2 Changed 4 years ago by Piotrek Koszuliński

@j.swiderski's reply might be confusing. What he meant was that browser or PDF viewer or something else that works in the middle doesn't provide all the data in the clipboard. This is what HTML is available when we get it: https://gist.github.com/Reinmar/d51aea326d03f6a23289. As you can see there's nothing after the table. I don't know whose fault is that, but definitely not CKEditor's, so it's "can't fix".

PS. The weird thing is that most likely all of us tested this on different OSes and PDF viewers (my setup - MacOS and Preview) as well as on different browsers. Strange that in all this cases the same bit of information is missing. It may mean that there's also something wrong with this PDF that you attached.

comment:3 Changed 4 years ago by Jakub Ś

@Reinmar thanks for clearing this up. I believe I have by accident removed middle of my response because the above sentence doesn't make any sense.

comment:4 Changed 4 years ago by sushil

When we were testing the behavior on our environment it was surprising to us as well. Thus we tested the PDF with the demo app on the CKEditor website and it was reproducible there as well. When I use the Paste text option or paste option, it gets all the texts. It is probably something to do with the table and its formatting in the PDF.

However, guys thanks for your time and analysis.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy