Opened 12 years ago

Closed 12 years ago

#1332 closed Bug (worksforme)

Empty <blockquote> is created when getting a paragraph out of it

Reported by: Aaron van Geffen Owned by:
Priority: Normal Milestone: FCKeditor 2.5 Beta
Component: General Version: SVN (FCKeditor) - Retired
Keywords: Pending Cc:

Description (last modified by Frederico Caldeira Knabben)

An empty <blockquote> is created when getting a paragraph out of it. Steps to reproduce:

  1. Activate the "Show Blocks" feature
  2. Start typing some text
  3. Activate the blockquote feature
  4. Strike [enter] to make a new paragraph
  5. Type some text again
  6. Set the caret to the second paragraph
  7. Deactive the blockquote feature

This will get the <p> out of the <blockquote>, but will also create an empty <blockquote> after the <p> element.

Change History (7)

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Description: modified (diff)

Reformatted the description for readability.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending added
Milestone: FCKeditor 2.5

I'm not able to reproduce it with the steps you have described. I believe there is something else in step 6.

But, while playing with the blockquote, I've faced this bug. I was not able to reproduce it again, but it seams that there is a rare situation when this thing happen.

Can you or someone else add more info to these steps so we can consistently reproduce it?

comment:3 Changed 12 years ago by Aaron van Geffen

I should probably mention I'm using Firefox 2.0.0.7 on Windows XP SP2, and last night's build.

comment:4 Changed 12 years ago by Frederico Caldeira Knabben

I'm also testing it with FF2, but I'm still not able to reproduce it.

comment:5 Changed 12 years ago by Martin Kou

I've tried reproducing the bug on FF2, but I couldn't get any success.

Video of how I tried to reproduce it.

comment:6 Changed 12 years ago by Aaron van Geffen

I can't seem to reproduce it anymore either. Sorry for bothering you with it.

comment:7 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed

That's great Aaron! Thanks for your time on testing it.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy