Opened 4 years ago

Closed 4 years ago

#13324 closed Bug (duplicate)

insert link with css class using insertHtml

Reported by: Michael de Graaf Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Having a css file loaded, inserting a link with a class specified in this css file using insertHtml fails with an error:

  • (Dutch) Kan de eigenschap scrollIntoView van een niet-gedefinieerde verwijzing of een verwijzing naar een lege waarde niet ophalen
  • (Translated) Unable to get property 'scrollIntoView' of undefined or null reference

This can be reproduced on the demo page, currently containing version 4.4.7: http://ckeditor.com/demo

In Windows 8.1, Internet Explorer 11, using the console run the following line-by-line:

CKEDITOR.instances.editor1.setData('');
CKEDITOR.instances.editor1.addContentsCss('http://foundation.zurb.com/docs/assets/css/docs.css');
CKEDITOR.instances.editor1.setMode('source');
CKEDITOR.instances.editor1.setMode('wysiwyg');
CKEDITOR.instances.editor1.insertHtml('<a href="http://www.ckeditor.com" class="button">CKEditor</a>','unfiltered_html')

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.4.7

This is a duplicate of #11234.

NOTE: disabling style inline-block for class button in two places fixes the problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy