Opened 4 years ago

Closed 4 years ago

#13349 closed Bug (invalid)

CKEditor with Jaws and Mac voice over is not working properly in Chrome

Reported by: Ramesh Ponnusamy Owned by:
Priority: Normal Milestone:
Component: Accessibility Version:
Keywords: Cc: ramesh.ponnusamy@…

Description

Hi,

Title is not read properly when focus goes into edit area.

I have given the title option while creating the ckeditor instance. The title is generated properly but jaws is not reading while we open the ckeditor in chrome. Firefox it reads properly

In Mac voice over it is not working in all the browsers. It just reads "Press Alt 0 for help frame" but not the title.

We need this to be fixed for accessibility compliance so please look into it as soon as possible

Change History (3)

comment:1 Changed 4 years ago by Jakub Ś

Status: newconfirmed
Summary: ckeditor with Jaws and Mac voice over is not working properly in ChromeCKEditor with Jaws and Mac voice over is not working properly in Chrome
Version: 4.4.7

I assume that you are talking about below case:

CKEDITOR.replace( 'editor1', {
     startupFocus : true,
     title : 'my same rich text'
} ); 

I will confirm this issue but it requires further checking however I think it should be marked as Feature and not a Bug.

The editor title is read nicely by JAWS in Firefox while in Chrome it depends. Sometimes it is read and sometimes nothing is. These are the results I got win Win8 latest editor, FF and Chrome. Same System, HTML, editor, JAWS and yet different results on two different browsers. Doesn't look like editor issue to me but perhaps there is something we can add (e.g. attribute) or change in that label so that it is read.

VoiceOver - to be checked. I need to test it on newer dev machine.

comment:2 Changed 4 years ago by Ramesh Ponnusamy

Yeah you are right about the title option. We have to support this in all the browsers for accessibility. If there is an issue with Jaws and Chrome combination please forward me the link where I can take a reference of and update our documentation.

comment:3 Changed 4 years ago by Marek Lewandowski

Resolution: invalid
Status: confirmedclosed

Unfortunately often times there's poor implementation for Assistive Technologies in some browsers or OSes. Our reference is Firefox + JAWS as it's the most stable combination for a long time. We're not able to do anything with browser / screen reader providers.

In case of JAWS I'd assume it's Chrome problem (since it works correctly with FF) so you want to look in Chrome tracking system if there's already a ticket for that, if not create the new one.

In case of VoiceOver I have no idea where the problem might be. So you might create ticket for both browsers and screen reader vendor.

More links:

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy