Opened 4 years ago

Closed 3 years ago

#13361 closed Bug (fixed)

images fail when site path includes parentheses because background-image path in ckeditor.js needs single-quotes around url value

Reported by: Jamie Owned by: Tomasz Jakut
Priority: Normal Milestone: CKEditor 4.5.5
Component: UI : Toolbar Version: 4.0
Keywords: Cc:

Description

Images (e.g. non-sprite toolbar images such as JustifyLeft, JustifyCenter, etc.) fail to display when the full site path includes parentheses (common in Visual Studio debug mode; e.g. "http://localhost:59847/(S(tlbjdb0xrjmmgdfeuii1hhdbaf5i))/") because background-image path in ckeditor.js needs single-quotes around url value.

To fix this, find the following code in ckeditor.js:

background-image:url("+CKEDITOR.getUrl(a)+");

...and change it to...

background-image:url('"+CKEDITOR.getUrl(a)+"');

Note the added single-quotes immediately inside the parentheses. Problem solved.

Change History (11)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: missing images toolbar removed
Status: newconfirmed
Version: 4.4.8 (GitHub - master)4.0

Note the added single-quotes immediately inside the parentheses

I can see single quotes are missing from CKEditor 4.0.

comment:2 Changed 3 years ago by Jamie

This bug arises on any page within an ASP.NET application that is using cookieless session state. So, it may be a very common problem. It is not limited to debug modes. (See ASP.NET configuration setting of cookieless="UseCookies | UseUri | UseDeviceProfile | AutoDetect".)

comment:3 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4

comment:4 Changed 3 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.4CKEditor 4.5.5

comment:5 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:6 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

comment:7 Changed 3 years ago by Piotr Jasiun

Status: reviewreview_failed

Code looks and works good. Well done.

Still there are some minor code style issues to fix:

  • tc tag is needed only for manual tests;
  • unit tag is not needed anymore, if there is no .md file test is automatically assume as "unit";
  • update your comment: ticket number should be at the end in the brackets "Comment. (#13361)";
  • break long lines; the line length should not be longer then 140 characters (120 is optimum).

comment:8 Changed 3 years ago by Tomasz Jakut

Status: review_failedreview

Pushed branch:t/13361

  • tc tag is used only in manual tests;
  • unit tag deleted
  • comment updated
  • long lines broken

comment:9 Changed 3 years ago by Piotr Jasiun

R+. Congrats :)

Changes are not merged into the master branch, because it is frozen, because of release.

I rebased branch and pushed some small changes to the t/13361.

comment:10 Changed 3 years ago by Piotr Jasiun

Status: reviewreview_passed

comment:11 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: review_passedclosed

Merged with git:e634323.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy