Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13383 closed Bug (invalid)

Allow remove focusmanager

Reported by: 613038475 Owned by:
Priority: Normal Milestone:
Component: Core : Focus Version:
Keywords: Cc:

Description

I need a option to remove focusmanager. focusmanager confict with other javascript modal dialog (bootstrap modal, jquery-ui), if there any modal window opened, all cke-dialog form field won't get focus and I can't find any way to fix it (I remove all tab-index attribute from all elements before and work a while, but broke again today). I don't understand what's the mean to use the stupid buggy focusmanager, browsers care it well.

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.4.8 (GitHub - master)

focusmanager confict with other javascript modal dialog (bootstrap modal, jquery-ui)

Please consider that it may be the other way around especially that many users have found solutions for thise kind of problems in jquery-ui and bootstrap.

I'm closing this issue for now. Please refer to this http://dev.ckeditor.com/ticket/13320#comment:4 for more details.

Last edited 4 years ago by Jakub Ś (previous) (diff)

comment:2 Changed 4 years ago by Piotrek Koszuliński

I don't understand what's the mean to use the stupid buggy focusmanager, browsers care it well.

I'm sorry, but it's pretty obvious from your bug report that you have little knowledge of what is really happening. You blame CKEditor's focus manager while these problems are caused by jQuery UI and Bootstrap modals code. The focus manager takes no part in this particular case.

Make sure to read https://gist.github.com/Reinmar/b9df3f30a05786511a42 – there are well known workarounds to fix jQuery UI and Bootstrap modals.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy