Opened 4 years ago

Closed 4 years ago

#13395 closed Bug (invalid)

Triple clicking a paragraph, then justifying (left/center/right) justifies the next paragraph too

Reported by: ryandeba Owned by:
Priority: Normal Milestone:
Component: General Version: 4.4.4
Keywords: Blink Webkit Cc:

Description

Steps to reproduce:

  1. Open http://ckeditor.com/demo#full in the latest version of Google Chrome
  2. Type two paragraphs (or switch to source mode and paste in: "<p>this is a paragraph.</p><p>this is a second paragraph.</p>")
  3. Triple click the first paragraph to select it.
  4. Click the Align Right toolbar button
  5. Both paragraphs get aligned right, even though the second paragraph was not selected.

Browser name and OS: Google Chrome Version 43.0.2357.81 m, Windows 8

Editor configuration: http://ckeditor.com/demo#full

This behavior did not seem to be present in CKEditor 4.4.3.

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: Blink Webkit added
Status: newconfirmed
Version: 4.4.74.4.4

Problem or change in behaviour can be reproduced from CKEditor 4.4.7 in Blink and Webkit browsers.

I have checked 4.4.3 and 4.4.7. In both versions endContainer is second paragraph but starting from CKE 4.4.4 alignment moves them both and not just one.

comment:2 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: confirmedclosed

In CKEditor 4.4.4 we closed the opposite ticket - #12178.

Since triple click makes a 2 paragraphs selection I think that 2 paragraphs should be changed, because we can hardly say what user wanted to do. And such behaviour handles case, when user wanted to select two paragraphs while one of them is empty:

<p>[bar</p>
<p>]</p>
<p>foo</p>

So I understand that this behaviour may be a little bit surprising, because it's not that well visible that the second paragraph is also selected, but at the same time it may he an expected behaviour for someone who knows that.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy