Opened 4 years ago

Closed 4 years ago

#13424 closed Bug (fixed)

Pasting autoembedable link with extra content embeds the link

Reported by: Szymon Cofalik Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Cc:

Description

There are cases when pasting some text with autoemedable links makes editor embed content in their place.

Steps to reproduce:

  1. In empty editor type foo bar
  2. Place caret between spaces
  3. Paste https://instagram.com/p/wZB11CIfqX/ and let it convert.
  4. Undo once, so you get foo https://instagram.com/p/wZB11CIfqX/ bar. Mind, that the link is converted to <a> element.
  5. Select everything (using mouse or alt+a).
  6. Cut and paste.

Expected result: Editor should contain foo https://instagram.com/p/wZB11CIfqX/ bar with the link being <a> element.
Result: The link is converted to embeded object.

Please note, that just pasting: foo https://instagram.com/p/wZB11CIfqX/ bar works correctly - the link is not converted.

Change History (2)

comment:1 Changed 4 years ago by Szymon Cofalik

Component: UI : WidgetsGeneral

comment:2 Changed 4 years ago by Jakub Ś

Keywords: chrome ie ff opera autoembed removed
Resolution: fixed
Status: newclosed

This issue seems to have been fixed in CKEditor 4.5.2. I could not reproduce this problem in that version.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy