Opened 4 years ago

Closed 4 years ago

#13426 closed Bug (invalid)

Empty inline elements are removed from the embedded content

Reported by: Szymon Cofalik Owned by:
Priority: Low Milestone:
Component: General Version: 4.5.0
Keywords: Cc:

Description (last modified by Szymon Cofalik)

When autoembeding content, sometimes we end up with empty inline elements, which are then removed from the embedded content.

Steps to reproduce:

  1. In empty editor, paste http://tellto.tumblr.com/post/112160646328.
  2. Wait until the link converts.
  3. Look at source.

Expected result: There should be inline elements in <div data-oembed-url="http://tellto.tumblr.com/post/112160646328"> or the link should be correctly converted.
Result:

<div data-oembed-url="http://tellto.tumblr.com/post/112160646328">
<script async="" charset="utf-8" src="//cdn.iframe.ly/embed.js"></script>
</div>

Which has no graphical representation in WYSIWYG mode.

Change History (6)

comment:1 Changed 4 years ago by Szymon Cofalik

Description: modified (diff)

comment:2 Changed 4 years ago by Szymon Cofalik

Keywords: autoembed added

comment:3 Changed 4 years ago by Olek Nowodziński

Priority: NormalLow
Status: newpending

I'm unable to reproduce. It could be some random problem with iframely or something else, that we unknowingly fixed.

comment:4 Changed 4 years ago by Piotrek Koszuliński

You may not be able to reproduce it, because I cofigured Iframely differently. It now does not return these empty links or useless blockquotes with scripts. But the problem would still be possible to reproduce if you mock Iframely's response.

comment:5 Changed 4 years ago by Piotrek Koszuliński

Keywords: opera ie ff chrome autoembed removed
Milestone: CKEditor 4.5.2CKEditor 4.5.3

comment:6 Changed 4 years ago by Piotrek Koszuliński

Milestone: CKEditor 4.5.3
Resolution: invalid
Status: pendingclosed

OK, I can't find any resource that suffers from this issue now. Also, I don't see an easy way to change parser's behaviour, so I'm not sure if we would be able to do anything.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy