Opened 4 years ago

Closed 3 years ago

#13436 closed Bug (worksforme)

[D&D] Inline image from inline editor

Reported by: Szymon Cofalik Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description (last modified by Szymon Cofalik)

D&D image from inline editor into other editor have incorrect results.

Browser: Opera, maybe others.

Steps to reproduce:

  1. Setup your editors like this:
    <div id="classic">
    	<img alt="CKEditor logo" src="/tests/_assets/logo.png" />
    </div>
    <div id="inline" contenteditable="true">
    	<img alt="CKEditor logo" src="/tests/_assets/logo.png" />
    </div>
    <script>
    	CKEDITOR.replace( 'classic' );
    	CKEDITOR.inline( 'inline' );
    </script>
    
  2. Try to D&D the image from inline editor into classic editor.

Expected result: Image is correctly drag and dropped from one editor into another.

Result: Nothing happed.

Note: Everything works fine if you type some text, select the image with the text and D&D with the text.
Note: Same happens when the destination editor is also inline.
Note: During playing with this bug I managed to get string like data:image/png;base64,iVBORw0KGgoAAAA... as a result of D&D, but I can't reproduce it now :(

You can test it here: http://tests.ckeditor.dev:10450/tests/plugins/clipboard/manual/draganddrop

Change History (3)

comment:1 Changed 4 years ago by Szymon Cofalik

Description: modified (diff)

comment:2 Changed 4 years ago by Szymon Cofalik

Description: modified (diff)

comment:3 Changed 3 years ago by Jakub Ś

Resolution: worksforme
Status: newclosed
Version: 4.5.0

From what I have checked, D&D for inline images seems to work in CKEditor 4.5.7 just fine.

I have checked D&D between inline editors and classic/inline. All work as expected. Problem most likely has expired on master.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy