Opened 4 years ago

Closed 4 years ago

#13476 closed Bug (invalid)

'full-width space' is not pasted on firefox and IE

Reported by: yuhai Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Summary: The issue can't be reproduced on chrome. And it can be reproduced on firefox and IE

Reproduce Steps:

  1. Use firefox, go to http://ckeditor.com/demo#bbcode demo.
  2. Enter one full-width space and word "test", and click enter.
  3. Ctrl+C to copy the first line.
  4. Ctrl+V to paste the content in the second line.

Actual behavior: 'full-width space' is not pasted. Please refer to the attachment.

Expected behavior: 'full-width space' is pasted successful.

I find: On firefox, pastebin.getHtml() is right. On chrome, pastebin.getHtml(): the content is included in <span> label. I think <span> label is generated by chrome. Is it right? For span label, can we prevent it (This is not mainly issue in the ticket. If needed, I will create one new ticket to report it. I see the related thread from http://ckeditor.com/forums/CKEditor/Clipboard-Chrome-and-Keyboard-Ctrl-C)?

To type full-width spaces, you need to install the Japanese IME This link might be useful: https://www.coscom.co.jp/learnjapanese801/install_ime.html

Please help check the issue.

Thanks, Hai

Attachments (1)

reproduced_firefox.gif (399.3 KB) - added by yuhai 4 years ago.

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by yuhai

Attachment: reproduced_firefox.gif added

comment:1 Changed 4 years ago by yuhai

Version: 4.4.54.4.7

comment:2 Changed 4 years ago by Piotrek Koszuliński

Status: newpending
Version: 4.4.7

Could you check it on e.g. http://ckeditor.com/tmp/4.5.0-beta/image-upload.html? This sample uses CKEditor 4.5 Beta which uses the Clipboard API to access the clipboard in browsers that support it. Firefox does support this API, so perhaps this bug would be fixed. But IE don't, so nothing will change.

comment:3 Changed 4 years ago by yuhai

Hi Reinmar,

Thanks for your response.

It works on firefox when test the issue in http://ckeditor.com/tmp/4.5.0-beta/image-upload.html.

I have two questions. Why http://ckeditor.com/demo#bbcode can reproduce the issue on firefox? And the ckeditor demo version is 4.4.7. Can you let me know which ticket fix the issue on firefox?

Thanks, Hai

comment:4 Changed 4 years ago by Piotrek Koszuliński

http://ckeditor.com/demo uses still CKEditor 4.4.7. This was fixed (or rather - worked around) in 4.5.0 and there's no single ticket. It was a big set of tickets that made CKEditor use the Clipboard APIs and extract the contents of the DOM manually, rather than letting the browser do it. So if you hoped to apply a patch to 4.4.7, then the closest you can get to that is to upgrade to CKEditor 4.5.0.

comment:5 Changed 4 years ago by yuhai

Hi Reinmar,

Make sense.

Thanks, Hai

comment:6 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

It works on firefox when test the issue

I think we can close this ticket since it works in 4.5.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy