Opened 3 years ago

Closed 3 years ago

#13508 closed Bug (invalid)

Undo/redo widget issue

Reported by: Radoslav Petkov Owned by:
Priority: Normal Milestone:
Component: Core : Undo & Redo Version:
Keywords: Cc:

Description

I have encountered a problem with the focusmanager. I have used http://ckeditor.com/addon/layoutmanager to cause the exception.

Attachments (1)

undo_redo_widget_bug.gif (1.4 MB) - added by Radoslav Petkov 3 years ago.
gif showing how to reproduce the error

Download all attachments as: .zip

Change History (7)

Changed 3 years ago by Radoslav Petkov

Attachment: undo_redo_widget_bug.gif added

gif showing how to reproduce the error

comment:1 Changed 3 years ago by Piotrek Koszuliński

Keywords: widget undo redo removed
Status: newpending
Version: 4.5.1

Unfortunately we need the bug to be isolated. We cannot debug someone's plugin. So please limit the code to a minimum working sample and then we'll be able to investigate this issue.

comment:2 Changed 3 years ago by Radoslav Petkov

Do you provide somewhere a demo of the editor with the newest version?The one for widgets, does not support widget nesting.

comment:3 Changed 3 years ago by Jakub Ś

I don't think we have such demo at the moment but what @Reinmar meant is that we need very small widget code - reduced to the minimum where problem can be reproduced.

Could you prepare something like that?


I have noticed that this issue has already been reported #13334. I'm not sure however if the issue got into the release because it has no milestone.

@rpet have you adjusted your plugin to what was written in that ticket?

comment:4 Changed 3 years ago by Piotrek Koszuliński

Yes, #13334 was included in the 4.5.0. We forgot to set the milestone (corrected).

comment:5 Changed 3 years ago by Radoslav Petkov

@j.swiderski Yes i have used the the correct order of editables i think.The only problem i think is the dynamic init of editables but @scofalik told that this is not a problem in the ticket.

var uniqueId = new Date().getTime();
insertedCol.addClass('columnEditable' + uniqueId);
row.append(insertedCol);
selectedWidget.initEditable(uniqueId, {
  selector: '.columnEditable' + uniqueId + ''
});

This is the code snippet i use. Do i need to wait some time before the initEditable?

Last edited 3 years ago by Radoslav Petkov (previous) (diff)

comment:6 Changed 3 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

Sync calls to getTime() may yield the same results. Use at least Math.random() or some global counter (like CKEDITOR.tools.getNextNumber()).

So as I understand this was the problem. I'm closing this ticket. If this wasn't the problem we can of course reopen it later.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy