Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#13512 closed Bug (wontfix)

[IE11] The page will scroll down when enter key is hit in CKEditor when browser is not full sized

Reported by: Feng Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IE11 Cc:

Description

This is a problem similar to https://dev.ckeditor.com/ticket/12119.

Reproduce: Using IE11, when the page height is set to 100%, and the page compatMode is backmode, and *when browser is not full expended*, the page will scroll down when enter key is hit in CKEditor.

I did take the approach as https://dev.ckeditor.com/ticket/12119 suggested and take the HTML4 doctype as the configuration. So it fixes the scrolling problem when browser is full screened. But when you re-size the brower screen, this scroll side effect would still happens.

Change History (4)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed
Version: 4.4.7

Compat mode is not supported on IE11. Only on IE8-9 we support it and only in limited ways. It's a too big cost to support more, because every single one is different.

http://docs.ckeditor.com/#!/guide/dev_browsers

comment:2 Changed 4 years ago by Feng

Hi Reimar, Sorry I mean quirks mode. I will edit the title and reopen this. (I copied wrong from previous ticket.)

comment:3 Changed 4 years ago by Feng

Actually could you help reopen this? I don't have the permission to reopen or edit the description.

IE11 Quirks mode must be supported by CKEditor. It is one of loose stardard html doctype.

comment:4 Changed 4 years ago by Piotrek Koszuliński

IE11 Quirks Mode is not supported. As in the http://docs.ckeditor.com/#!/guide/dev_browsers – only IE8-9 quirks mode and compat mode are supported, but only in a limited manner. Full support is not possible because this modes are pushing browsers to behave in an extremely old way. If you require support for IE QM please see http://cksource.com/ckeditor

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy