Opened 3 years ago

Closed 3 years ago

#13532 closed Bug (fixed)

Autoembed: Spontaneous re–embed of a link after undo and paste a non–embeddable content

Reported by: Olek Nowodziński Owned by: Olek Nowodziński
Priority: Normal Milestone: CKEditor 4.5.2
Component: Core : Pasting Version: 4.5.0
Keywords: Cc:

Description

  1. Open http://tests.ckeditor.dev:1030/tests/plugins/autoembed/manual/autoembed.
  2. Copy an URL.
  3. Paste the URL. The link becomes a widget.
  4. Undo.
  5. Place selection anywhere but not within a link.
  6. Copy and paste anything which is not embeddable.

Expected: Pasted a new content.

Actual: Pasted a new content and re–embedded the link.

Change History (6)

comment:1 Changed 3 years ago by Olek Nowodziński

Owner: set to Olek Nowodziński
Status: newassigned

comment:2 Changed 3 years ago by Olek Nowodziński

Status: assignedreview

comment:3 Changed 3 years ago by Piotr Jasiun

Status: reviewreview_failed

You set embedCandidatePasted after if(transferType == INTERNAL) return; so:

1-5. Same.

  1. Copy and paste anything intently in the editor.

Give the same result as before the fix.

Also ticket manual test would be useful witch steps to reproduce this ticket, for reviewer and the next release testers).

Additionally one line of description would be useful at the line where new variable is defined or used for the first time, now there is only ticket number at the last usage of it. It could also note that embedCandidatePasted should be set before any return.

Last edited 3 years ago by Piotr Jasiun (previous) (diff)

comment:4 in reply to:  3 Changed 3 years ago by Olek Nowodziński

Status: review_failedreview

Nice catch!

Replying to pjasiun:

You set embedCandidatePasted after if(transferType == INTERNAL) return; so:

1-5. Same.

  1. Copy and paste anything intently in the editor.

Give the same result as before the fix.

Fixed in branch:t/13532b.

Also ticket manual test would be useful witch steps to reproduce this ticket, for reviewer and the next release testers).

It's hardly necessary if the issue is fully covered by AT. KISS.

Additionally one line of description would be useful at the line where new variable is defined or used for the first time, now there is only ticket number at the last usage of it. It could also note that embedCandidatePasted should be set before any return.

Done.

comment:5 Changed 3 years ago by Olek Nowodziński

Pushed manual test to ​branch:t/13532b.

comment:6 Changed 3 years ago by Piotr Jasiun

Resolution: fixed
Status: reviewclosed

So it is fixed.

git:0d71fa2

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy