Opened 3 years ago

Closed 3 years ago

#13535 closed New Feature (wontfix)

Table plugin default values

Reported by: Fabien Leconte Owned by:
Priority: Normal Milestone:
Component: Core : Tables Version: 3.0
Keywords: Cc:

Description

Hi,

It would be really useful to be able to configure the defaults values of the "Table" plugin.

The following values shouldn't be hard-coded :

  • lines
  • columns
  • width
  • cellspacing
  • cellpadding
  • border

Thanks.

Regards.

Change History (2)

comment:1 Changed 3 years ago by Jakub Ś

Status: newconfirmed
Version: 4.5.2 (GitHub - master)3.0

Table attributes are now deprecated in HTML5 http://www.w3schools.com/tags/tag_table.asp and I don't think we will be introducing them in e.g. CKEditor 5.

Since CKEditor 4 still supports HTML 4 (and perhaps tables will be rewritten) then this is quite interesting feature request with which I agree. There should be a way to define all these values.
We had many requests about default table width not being configurable or that it should be 100%. Users didn’t like our approach in this case.
I believe that we should provide default values but also a way to change them (configuration option which accepts array or object). In other words, the more freedom we give our users the more happy users we will have.

comment:2 Changed 3 years ago by Marek Lewandowski

Resolution: wontfix
Status: confirmedclosed

@froggie you can override default values yourself using editor#dialogShow event. To create a new plugin and then listen for that event (and ensure that it comes from table dialog, because every dialog will report such trigger) - that will keep your config clean and improve maintainability.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy