Opened 4 years ago

Closed 4 years ago

#13586 closed Bug (invalid)

single ckeditor instance for ng-repeat

Reported by: shri2015 Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: shridhar.hsn@…

Description

ckeditor instance creating for each loop and it is creating with same name.

So on finding the instance from CKEDTIOR,it showing only one instance but on f12 it showing muliple instance.how to get the perticular instance.

Its created ckedtior with the same name "sample-{{$index}}". But the div control id is unique.

<div data-ng-repeat="(i, Option) in node.Options track by $index">

<div id="sample-{{$index}}" class="nText" contenteditable='true'

ckeditor="htmlEditorOptions" data-placeholder={{node.EditOption}} data-ng-model="node.Options[i]"></div>

</div>

Change History (5)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Keywords: single instance for ng-repeat removed
Status: newpending
Version: 4.5.1

I'm sorry, but I have no idea what you mean. You will need to create a limited and working sample that shows the issue and describe steps to reproduce it. Also, please note that such sample should not include Angular, because it will be impossible for us to understand what's going on there.

comment:2 Changed 4 years ago by shri2015

In the code snippet ,node is the json object it has been used as model and node.Options contains multiple values and these values am binding using ng-repeat and creating content editable div with ckeditor attribute for each value of node.Options.

if we look in console CKEDITOR.instances it showing only one instance.but in DOM its creating multiple ckeditor instance corresponding to the node.Options with the same id as "sample-{{$index}}".

So here my concern is why CKEDITOR.instances is having only one instance with the name "sample-{{$index}}" ,if we observe {{$index}} is not replace with actual value. ckeditor instance is creating.

comment:3 Changed 4 years ago by shri2015

i found one more similar question for which no body answered http://stackoverflow.com/questions/28715234/assign-id-to-ckeditor-inside-the-ng-repeat

comment:4 Changed 4 years ago by shri2015

Cc: shridhar.hsn@… added

comment:5 Changed 4 years ago by Piotrek Koszuliński

Resolution: invalid
Status: pendingclosed

From what I understand it's not a bug report, but a question why CKEditor Angular directive (which is not part of the CKEditor official project) work in this way and not another.

I'm closing this ticket as invalid because we have nothing here we could work on.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy