Opened 4 years ago

Closed 3 years ago

#13639 closed Bug (fixed)

Unable to create a new line on Firefox Mobile

Reported by: Wiktor Walc Owned by:
Priority: Normal Milestone:
Component: UI : Enter Key Version: 4.5.2
Keywords: Cc:

Description (last modified by Wiktor Walc)

Steps to reproduce

  1. Firefox (mobile) 39, Android 4.4.2
  2. Load http://ckeditor.com/latest/samples/
  3. Type something and try moving to the next line by pressing "enter".

Expected result

The cursor is moved to the next line.

Actual result

The cursor blinks in the next line, but after typing a character, the text is entered back in the previous line. It is impossible also to press "enter" a few times.

Other details (browser, OS, CKEditor version, installed plugins)

Did not try earlier versions as Firefox Mobile was disabled by default in earlier versions of CKEditor. See also bug report on youtube: https://www.youtube.com/watch?v=mLf9pPj9FTM

Change History (9)

comment:1 Changed 4 years ago by Wiktor Walc

Description: modified (diff)
Status: newconfirmed

comment:2 Changed 3 years ago by Alessandro

there are news on this? if occur i could offer more videos (i am the author of video on youtube)

comment:3 Changed 3 years ago by kkrzton

It is not a CKEditor bug, but native bug in Firefox on Android. Happens in non empty contenteditable element. I can see it was already reported to Mozilla some time ago: https://bugzilla.mozilla.org/show_bug.cgi?id=1040445.

comment:4 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:5 Changed 3 years ago by kkrzton

Owner: kkrzton deleted
Status: assignedconfirmed

comment:6 Changed 3 years ago by Alessandro

I can't reproduce same issue on 45.0b2 firefox beta for android.

comment:7 Changed 3 years ago by kkrzton

I checked on 45.03b and it seems to work well, can't reproduce it anymore. It means the issue should be resolved in the upcoming versions of Firefox Mobile (when beta will become stable version).

comment:8 Changed 3 years ago by Jakub Ś

Related issue: #14383

comment:9 Changed 3 years ago by kkrzton

Resolution: fixed
Status: confirmedclosed

The bug in FF was fixed (https://bugzilla.mozilla.org/show_bug.cgi?id=1040445) and this issue does not occur anymore in newest FF for Android (checked with 46.0.1).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy