Opened 4 years ago

Closed 4 years ago

#13671 closed New Feature (invalid)

Feature Request: Image handling (want to paste pictures directly - without plugin)

Reported by: Michael Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

Try to paste an image directly in the ckEditor.

Expected result

The picture is bound in the text and no separate Image browser is necessary. The picture should be saved on the server so that no explicit upload is required. The file location is not important. It should be how in the simpleuploads-plugin (http://ckeditor.com/addon/simpleuploads). The current behave is outdated and requires a lot of klicks for an author. We want to simplify the life of an author.

Actual result

You must go over the Image browser.

Other details (browser, OS, CKEditor version, installed plugins)

This should be a direct feature of ckEditor. Because of the uncertainty that the plugin will be further developed it is difficult to implement this in a productive environment. The risk is that we can't use updates in future, because of a plugin who needed a special version to run.

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.2

Please see http://sdk.ckeditor.com/samples/fileupload.html. These features were introduced not so long ago but are not available by default - they need to be enabled.

Image handling (want to paste pictures directly - without plugin)

These features where introduced as set of plugins which users can choose or not. This is much better approach than putting them straight into core.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy