Ticket #1370 (closed New Feature: wontfix)

Opened 7 years ago

Last modified 2 years ago

Firefox 2.0 - Spell Checking - Add to Dictionary

Reported by: staratnight@… Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: SF CantFix Firefox Cc:

Description

The newest version of the firefox browser allows spell checking in textareas.

So in FCKEditor spell ckecking works well.

Spell checking dictionaries have to grow to be useful in daily use, so firefox allows to add unknown words to a users dictionary by rightclicking the underlined word and choosing "add to user dictionary" in the context menu.

In FCKEditor it is not possible to add new words, because the context menu is overwitten with "Copy Cut Paste" in the textarea.

It would be great to give control back to the browser to use this brilliant feature (maybe configurable in config file).

I know there are several areas of context menus (i.e. tables, lists,...). It would be perfect if FCKE could check for underlined words and react. For simple solution it could only work in the "generic" part of the trextarea.


Moved from sourceforge
Original author: Torsten Mingers

Change History

comment:1 Changed 7 years ago by alfonsoml

  • Reporter changed from alfonsoml to staratnight@…

We have already partially fixed this problem by disabling the spell checker in FCKeditor. At least users will not get confused. The fix is in the SVN.

You can also find a plugin which enables FF's spell checker: https://sourceforge.net/tracker/index.php?func=detail&aid=1581776&group_id=75348&atid=737639

I'm moving your report to the Feature Requests, because it would be really nice to be able to identify whenever the user right click is over a misspelled word and them show the original Firefox menu.

Let's see if we find out something regarding it.


Original author: FredCK

https://sourceforge.net/tracker/index.php?func=detail&aid=1399961&group_id=75348&atid=543656 and https://sourceforge.net/tracker/index.php?func=detail&aid=1578680&group_id=75348&atid=543656 have been marked as duplicate of this one.

comment:2 Changed 2 years ago by j.swiderski

  • Status changed from new to closed
  • Resolution set to wontfix

I believe this works fine now in CKEditor.

FCKeditor is no longer supported. Closing this ticket.

Note: See TracTickets for help on using tickets.
© 2003 – 2012 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy