Opened 4 years ago

Closed 4 years ago

#13716 closed Bug (duplicate)

Redo is broken for Widgets

Reported by: ferahl Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.3
Keywords: Cc:

Description

Steps to reproduce

  1. Go to http://sdk.ckeditor.com/samples/mediaembed.html
  2. Double click the YouTube embed to edit the URL
  3. Enter a different URL e.g
    https://www.youtube.com/watch?v=_W9ewqSjkKk
    
  1. Undo then Redo -> works
  2. Undo
  3. Click off the editor (blur)
  4. Click back on to the editor and try observe the Redo button is active - click it

Expected result

Clicking Redo changes the state to the latest one (the video change).

Actual result

Nothing happens.

N.B If you had more Undo states before this, then going back to them and then Redoing to the end will allow you to do the final Redo, but it is an empty state with only a selection change (from non-selected widget to selected widget)

N.B On my own widget it only breaks if when coming back into the editor I click on something other than the widget and click Redo. But it seems broken either way on the sample page.

N.B Tested to be broken on 4.4.8 as well

Other details (browser, OS, CKEditor version, installed plugins)

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: widget undo redo removed
Resolution: duplicate
Status: newclosed

After some checking I have realised that this is a duplicate of #13800

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy