Opened 4 years ago

Closed 4 years ago

#13720 closed Bug (wontfix)

Hard to erase a heading line when it's first

Reported by: Lyuba Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Start with the following content:

<h1>header</h1>

<p>paragraph</p>

  1. Double click the heading and erase it, you are left with a blank header line.
  1. Press delete to get rid of empty line - see that the paragraph become h1 style.

Expected result

Able to easily remove the header line.

Actual result

Seems I must bring the paragraph up which becomes header, and then change its style back to normal. The extra step of resetting the style is not super intuitive. Would be great if that wasn't necessary.

Other details (browser, OS, CKEditor version, installed plugins)

Reproducible on http://ckeditor.com/demo

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.5.3

I assume that you are talking about Chrome and IE11 since Firefox seems to work fine.

Now the problem is that this is how these browsers work in contenteditable elements and there is nothing we can do about it. You can verify it by running below code in browser. Please note that CKEditor is not needed to reproduce this issue.

<div style="margin:20px; border:1px solid black; width:500px;" contenteditable="true">
	<h1>XYZ</h1>
	<p>abc</p>
</div>
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy