Opened 4 years ago

Closed 4 years ago

#13741 closed Bug (wontfix)

Text selection direction lost

Reported by: Chris Kerekes Owned by:
Priority: Normal Milestone:
Component: Core : Selection Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Navigate to http://ckeditor.com/demo
  2. Place the cursor in the end of the editor.
  3. While holding down the shift key and press the up arrow key a couple times
  4. Open the console and enter the command CKEDITOR.instances.editor1.getSelection().selectRanges(CKEDITOR.instances.editor1.getSelection().getRanges());
  5. Close the browser console (as to refocus the editor without losing selection)
  6. While holding down the shift key press the up arrow key.

Expected result

The selection expands to encompass the contents in the line above the selection.

Actual result

The selection shrinks such that the last line in the document is no longer selected.

Other details (browser, OS, CKEditor version, installed plugins)

Tested in Chrome 45, IE 11 and FF 35 (all running on a windows 7 PC)

Change History (1)

comment:1 Changed 4 years ago by Piotrek Koszuliński

Resolution: wontfix
Status: newclosed
Version: 4.5.3

Selection direction is not supported in CKEditor 4 for historical reasons (it was not part of the original API). We will fix this in CKEditor 5. I'm closing this ticket as "won't fix" because it could not be fixed in this version (CKE5 has (will have, actually) a separate bug tracker - https://github.com/ckeditor/ckeditor5/issues).

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy