Opened 4 years ago

Closed 4 years ago

#13764 closed Bug (invalid)

Unable to bind html to ckeditor in edit mode

Reported by: Anand Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I have created multiple ckeditors dynamically by clicking on a button, finally saving all ckeditor data into database, in edit mode i am showing data in respective ckeditor but first ckeditor is not displaying the data when the page is initially loads if i refresh the page first ckeditor is biding, below is the code i am using

CKEDITOR.instances.editor1.setData(val.sectionContent()); CKEDITOR.instances.editor1.updateElement();

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.3

I have created multiple instances of the editor, checked now setData works with them and I find no issues.

CKEDITOR.on( 'instanceReady', function( e ){
	e.editor.setData('<div>dd</div>');
});	
  1. It might be a problem with val.sectionContent()
  2. Another possibility is a problem with your server-side. If data is loaded from the server, perhaps it is not delivered for the first editor?

I'm closing this ticket as invalid because I don't see any problem with the editor here.

@Anand If you still think there is a problem with the editor, please provide reduced sample which allows reproducing this issue in default CKEditor package, without any server-side.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy