Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13789 closed Bug (invalid)

Incompatible with Codemirror in Chrome

Reported by: Shawn Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc: shawn@…

Description

Steps to reproduce

  1. Install Codemirror plugin
  2. Open CKEditor in Chrome
  3. Write content into CKEditor
  4. Click on source mode

Expected result

Source mode should be opened with html contents of the editor highlighted.

Actual result

Contents are deleted and CKEditor errors out. No response from CKEditor after this.

Other details (browser, OS, CKEditor version, installed plugins)

Works in FireFox 40 and 41. Works in IE 11. Fails in Chrome 45. Fails in CKEditor version 4.5.3 Worked in CKEditor version 4.3.3 (just upgraded from this)

Error message: Uncaught InvalidCharacterError: Failed to execute 'add' on 'DOMTokenList': The token provided ('cke_source cke_reset cke_enable_context_menu') contains HTML space characters, which are not valid in tokens. ckeditor.js:79

Change History (4)

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Plugin: Codemirror removed
Resolution: invalid
Status: newclosed

Its Codemirror plugin which has to be compatible with CKEditor.

Please report this to plugin author.

comment:2 Changed 3 years ago by Shawn

If you had taken a moment to look at it you would have seen that it is CKEditor's failure to properly handle a properly formatted class list. And only in Chrome. So that is a CKEditor issue or a Chrome issue. Codemirror, which worked in earlier versions of CKEditor has not changed, it is CKEditor that has failed to implement code that can handle a class list that is longer than one class in the new version.

comment:3 Changed 3 years ago by Shawn

But I will turn this in to the author of Codemirror as well.

Thanks

comment:4 Changed 3 years ago by Jakub Ś

Version: 4.5.3

I have checked this issue in Google Chrome in CKEditor 4.5.3 and didn't get this problem. I have just tried changing to source mode with initial content and some newly entered content.

Perhaps you haven't cleared browser’s cache and that is why you got this problem.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy