Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13801 closed Bug (duplicate)

Japanese Multi-Byte Character doesn't work after Clicking Bold or any other CKE operation

Reported by: Abhishek Gupta Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: General Version: 4.5.0
Keywords: Cc: mrafique@…

Description

Steps to reproduce

  1. Click Bold option button
  2. Type multi byte character (Dont' use copy & paste when you try reproducing this.)

これは ( k o r e h a )

  1. これは entry is not displaying properly

kおrえhあ

Expected result

Multi-byte characters should be displayed properly

Actual result

Multi-byte characters are not displayed properly instead each keypress is displayed individually.

Other details (browser, OS, CKEditor version, installed plugins)

Chrome only issue. Can be reproed on http://ckeditor.com/demo standard version. Removing "undo" plugin fixes the issue but that limits CKE's api like "change" event handler etc.

Change History (10)

comment:1 Changed 3 years ago by Tariq

Cc: mrafique@… added

comment:2 Changed 3 years ago by Jakub Ś

Status: newconfirmed
Version: 4.5.44.5.0

Problem can be reproduced from CKEditor 4.5.0 in Blink browsers (Safari on Mac is ok)

comment:3 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5

Interesting fact is that it won't occur if it's typed very fast, so if you can't reproduce try to type a little slower.

By the look of things IME composition looks to be interrupted.

comment:4 Changed 3 years ago by Marek Lewandowski

You might not be able to repro it on a new sample, it's reproducible e.g. on old image2 sample.

comment:5 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:6 Changed 3 years ago by Marek Lewandowski

This issue might be fixed by #13816.

comment:7 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5CKEditor 4.5.6

comment:8 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:9 Changed 3 years ago by Marek Lewandowski

Resolution: duplicate
Status: assignedclosed

DUP of #13377.

comment:10 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy