Opened 3 years ago

Closed 3 years ago

#13827 closed Bug (invalid)

Font(Dropdown) Not Working in IE Popup.

Reported by: Rajesh Owned by:
Priority: Normal Milestone:
Component: UI : Toolbar Version: 3.6.6
Keywords: Cc:

Description

Using C#: Add CKEditor .dll

include CKeditor in popu window,

1) IE not working properly

Font & Size dropdown not properly showing.

Attachments (1)

Untitled.png (114.6 KB) - added by Rajesh 3 years ago.

Download all attachments as: .zip

Change History (2)

Changed 3 years ago by Rajesh

Attachment: Untitled.png added

comment:1 Changed 3 years ago by Jakub Ś

Keywords: Font removed
Resolution: invalid
Status: newclosed

First of all you need to upgrade the editor because version 3.x is no longer actively maintained:

You have written you are using CKEditor for ASP.NET 3.6.6.2 Please bear in mind that you can update client side version to CKEditor 4.5.4.

Download CKEditor 3.6.6.2 for ASP.NET, unpack, go to your-ckeditor-aspnet-3.6.6.2-folder\_Samples and delete \ckeditor\ directory. Download FULL package for CKEditor 4.5.4 and extract it to \ckeditor\ directory. Next copy \ckeditor\ directory to your-ckeditor-aspnet-3.6.6.2-folder\_Samples.

In CKEditor 4.1 we have introduced ACF. You can read about it here: http://ckeditor.com/blog/Upgrading-to-CKEditor-4.1
http://ckeditor.com/blog/CKEditor-4.1-RC-Released
http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter
http://docs.ckeditor.com/#!/api/CKEDITOR.filter-method-addTransformations
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-allowedContent
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-extraAllowedContent

If you plan to use content filter please note that CKEditor for ASP.NET 4.x is still under construction and to change ACF settings you would have to use config.js as it can’t be done from control level.


Now the problem with dropdowns in popups can be caused by the following thins:

  • If you are using jQuery UI 1.1.0.0 and above or Bootstrap, please see:

https://gist.github.com/Reinmar/b9df3f30a05786511a42 and http://bugs.jqueryui.com/ticket/9087#comment:30

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy