Opened 3 years ago

Closed 3 years ago

#13876 closed Bug (duplicate)

tab plugin does not support keyTabTools if tabSpaces > 0

Reported by: Shawn A Owned by:
Priority: Normal Milestone:
Component: Core : Keystrokes Version:
Keywords: Cc:

Description

Steps to reproduce

  1. set tabSpaces to 10
  2. click into a table cell
  3. press tab

Expected result

next cell should be selected

Actual result

nbsp is inserted with respect to tabSpaces as if we were NOT inside a table

Other details (browser, OS, CKEditor version, installed plugins)

chrome, latest cke, windows

The logic block in the plugin is backwards, if tabspaces > 0 then event.cancel is called before the keyTabTools can be evaluated. These should be reversed so that if keyTabTools is true, it checks if it is inside a table FIRST, so it can do its thang.

possible fix

swap

if ( tabText){...}

and

if ( tabTools ) {...}

blocks around

So that the tabTools condition occurs BEFORE the tabText one

The way it is now keyTabTools=true does nothing, if tabSpaces is > 0 since tabSpaces always event.cancel's if so.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.4

DUP of #10517

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy