Opened 4 years ago

Closed 4 years ago

#13881 closed Bug (invalid)

Allowed attributes, allowed class sanitized by toggling source

Reported by: Josh Owned by:
Priority: Normal Milestone:
Component: UI : Source View Version:
Keywords: Cc: joshuajmark@…

Description

Steps to reproduce

  1. Allow class attribute on tables
  2. Allow specific class
  3. Add specified class on table element using source. Toggle source off, the class is sanitized and contains cke_show_border. Toggle source back on, class attribute is gone.

Expected result

Class is applied and available to edit in the future. Source can be toggled without clearing allowed classes.

Actual result

Allowed class is sanitized by toggling source

Other details (browser, OS, CKEditor version, installed plugins)

All OS, all browsers. CKE 4.5.4. Plugins: table, tableresize,quicktable

Attachments (1)

table.png (106.9 KB) - added by Jakub Ś 4 years ago.

Download all attachments as: .zip

Change History (2)

comment:1 Changed 4 years ago by Jakub Ś

Keywords: table class removed
Resolution: invalid
Status: newclosed
Version: 4.5.4

I haven't tested quicktable plugin because this is a third party plugin but I have tested other two and there are no problems.

  1. First off all you should allow classes and not attributes for tables.
    var editor = CKEDITOR.replace( 'editor1', {
    extraPlugins : 'tableresize',
    extraAllowedContent : 'table(*)' //'table(someClass)'
    });
    
  2. Second is that cke_show_border is assigned to body and not the table directly.

Changed 4 years ago by Jakub Ś

Attachment: table.png added
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy