Opened 3 years ago

Closed 3 years ago

#13897 closed Bug (duplicate)

No cachebust added to icons.png and icons_hidpi.png

Reported by: Brandon Owned by:
Priority: Normal Milestone:
Component: Project : CKBuilder Version: 4.5.4
Keywords: Cc: wim.leers@…

Description

Steps to reproduce

  1. Download a development build of CKEditor
  2. Add a custom plugin with icons (regular and hidpi)
  3. Use ckeditor.jar to build the editor

Expected result

When the build script creates the appropriate CSS files, i.e. editor_gecko.css, the image file references should have a cachebust using the 'timestamp' parameter that is used to load all of the javascript and CSS files (i.e. ?t=FNUB).

Actual result

No cachebust parameter is added to the image file includes, so a cached image file may be served, causing buttons not to line up with their actions on the toolbar

Other details (browser, OS, CKEditor version, installed plugins)

We are using CKEditor 4.5.4 and as needed we run ckeditor.jar to rebuild the editor, however when plugins or icons change we frequently see the above-referenced issue.

.cke_ltr.cke_hidpi .cke_button__undo_icon{background:url(icons_hidpi.png) no-repeat 0 -984px!important;background-size:16px!important}

Change History (2)

comment:1 Changed 3 years ago by Wim Leers

Cc: wim.leers@… added

comment:2 Changed 3 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed

This is in fact a duplicate of #10685.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy