Opened 3 years ago

Closed 3 years ago

#13909 closed Bug (worksforme)

Bleeding test for fake selection

Reported by: Marek Lewandowski Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: General Version: 4.5.5
Keywords: Cc:

Description (last modified by Marek Lewandowski)

On master we have bleeding test test auto fake selection.

We need to investigate what is the reason for this.

Change History (13)

comment:1 Changed 3 years ago by Marek Lewandowski

Description: modified (diff)

comment:2 Changed 3 years ago by Marek Lewandowski

Description: modified (diff)
Status: newconfirmed

comment:3 Changed 3 years ago by Marek Lewandowski

Version: 4.5.44.5.5 (GitHub - master)

comment:4 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:5 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.5CKEditor 4.5.6

This is not a recent regression it's at least since 4.4.7.

comment:6 Changed 3 years ago by Tomasz Jakut

Milestone: CKEditor 4.5.6CKEditor 4.5.5
Owner: Tomasz Jakut deleted
Status: assignedconfirmed

comment:7 Changed 3 years ago by Tomasz Jakut

Milestone: CKEditor 4.5.5CKEditor 4.5.6

I accidentaly changed the milestone while unassinging myself, so I'm reverting it.

comment:8 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedassigned

comment:9 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

The problem is caused by the change in Chromium codebase. For some time Chrome throws uncatchable error when someone tries to select more than one range. The detailed description of that problem is available on Chromium tracker.

Therefore the only solution that works is preventing Chrome from trying to select more than one range at once. It seems to be a cosmetical change, because before changes in Chromium selecting more than one range resulted in selecting only the first one.

Pushed branch:t/13909.

comment:10 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.6CKEditor 4.5.7

comment:11 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7CKEditor 4.5.8

comment:12 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8CKEditor 4.5.9

comment:13 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9
Resolution: worksforme
Status: reviewclosed

It looks that this problem has been fixed by the Chromium team, and Chrome no longer throws this exception.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy