Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#13919 closed Bug (fixed)

[Edge] CKEDITOR.dom.node#isReadOnly crashes window when in the context of an input

Reported by: Marek Lewandowski Owned by: Marek Lewandowski
Priority: Normal Milestone: CKEditor 4.5.5
Component: General Version: 4.5.5
Keywords: Cc:

Description (last modified by Marek Lewandowski)

Recent update for Edge brought a regression that if you check .isContentEditable property on an input element it will crash.

It happens only in built CKE distribution as it includes bidi plugin, which injects .isReadOnly() check to setAttribute method.

This is very similar to #13609.

Change History (9)

comment:1 Changed 3 years ago by Marek Lewandowski

Description: modified (diff)

comment:2 Changed 3 years ago by Marek Lewandowski

Owner: set to Marek Lewandowski
Status: newassigned

comment:4 Changed 3 years ago by Marek Lewandowski

Status: assignedreview

Pushed to t/13919 at dev.

comment:5 Changed 3 years ago by Olek Nowodziński

Status: reviewreview_failed

The fix looks ok, but it needs tests (for textarea and input) around https://github.com/cksource/ckeditor-dev/blob/400e2a5d126bc6bbb16ee0d2fa3f682694b5c345/tests/core/dom/node.js#L189-L255 because

  1. The issue should be visible in dev, not only when BiDi is loaded and overrides CKEDITOR.dom.element.prototype in build.
  2. #13609 implemented no tests :(
  3. We should never meet this kind of issue again ;)

comment:6 Changed 3 years ago by Marek Lewandowski

Status: review_failedreview

Added test, I've used whole DTD so that we catch next regressions in the future.

Pushed to t/13919 at dev.

comment:7 Changed 3 years ago by Olek Nowodziński

Status: reviewreview_passed

comment:8 Changed 3 years ago by Olek Nowodziński

Resolution: fixed
Status: review_passedclosed

Merged git:400376f.

comment:9 Changed 3 years ago by Olek Nowodziński

Summary: [Edge] Failing tests[Edge] CKEDITOR.dom.node#isReadOnly crashes window when in the context of an input
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy