Opened 3 years ago

Closed 3 years ago

#14251 closed Bug (invalid)

Plugin requirement preventing editor from working properly when plugin is installed and enabled

Reported by: Adam De Lay Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Download Full install with Upload Image and oEmbed plugins (different errors for source version vs optimized version)
  2. Add config.imageUploadUrl to config.js with path to server side processing file for upload image.
  3. Add to web page and try to drag/drop image into editor

Expected result

I expect the editor to work just like the demo. When I drag and drop an image into the editor, it should save and display.

Actual result

Source download type: All editor toolbar buttons are grayed out and do not work. Console error states "[CKEDITOR] Error code: editor-plugin-required. Object {plugin: "toolbar", requiredBy: "notification"}". Here's the config.plugin list [config.plugins = 'dialogui,dialog,about,a11yhelp,dialogadvtab,basicstyles,bidi,blockquote,clipboard,button,panelbutton,panel,floatpanel,colorbutton,colordialog,templates,menu,contextmenu,div,resize,toolbar,elementspath,enterkey,entities,popup,filebrowser,find,fakeobjects,flash,floatingspace,listblock,richcombo,font,forms,format,horizontalrule,htmlwriter,image,indent,indentblock,indentlist,smiley,justify,menubutton,language,link,list,liststyle,maximize,newpage,pagebreak,pastetext,pastefromword,preview,print,removeformat,save,selectall,showblocks,showborders,sourcearea,specialchar,scayt,stylescombo,tab,table,tabletools,undo,wsc,lineutils,widget,oembed,filetools,notification,notificationaggregator,uploadwidget,uploadimage';]

Optimized download mode: Editor seems to work for the most part except the same error displays in the console "[CKEDITOR] Error code: editor-plugin-required. Object {plugin: "toolbar", requiredBy: "notification"}" and the uploadImage plugin saves the files to the server properly but it doesn't display them in the editor post-upload. When I try to debug the plugin file, it looks like the editor isn't even pulling it in.

Other details (browser, OS, CKEditor version, installed plugins)

Chrome 47.0.2526.73 m; CKEditor 4.5.6; Full plugin list as well as oEmbed and Upload Image plugins

Attachments (1)

Capture.PNG (39.4 KB) - added by Adam De Lay 3 years ago.
Console errors

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by Adam De Lay

Attachment: Capture.PNG added

Console errors

comment:1 Changed 3 years ago by Jakub Ś

Keywords: plugin removed
Status: newpending
Version: 4.5.6

Could you provide more details?

  1. Are you using http://ckeditor.com/addon/autoembed or http://ckeditor.com/addon/oembed
  2. Have you downloaded full package and then you have installed these two plugins manually?
  3. Could you provide you build-config.js, config.js and any other file were you configure CKEditor?
  4. Have you perhaps tried using the builder?

I'm not 100% sure butI believe the problem is caused by installing plugins manually. You must know that many plugins depend on each other. If you download image upload plugin, it informs you that it also needs upload widget. The upload widget on the other hand needs four other plugins.
When installing plugins like that you need to be aware of the dependencies. If you are just starting with CKEditor or don't have time to download plugins one by one, please use the builder. It will add plugins you want together with all the dependencies.

Was this the source of your problem?

comment:2 Changed 3 years ago by Adam De Lay

The "Steps to Reproduce" answer most of your questions. I get these errors when using the builder. I use the full installer and add 2 extra plugins (Upload Image and oEmbed).

comment:3 Changed 3 years ago by Jakub Ś

I have tried your setup (Full package plus imageupload and oembed) and didn't get any issues.

I have setup sample page with (I have use CKFinder for Java as backend):

var editor1 = CKEDITOR.replace( 'editor1', {
	extraPlugins: 'uploadimage,oembed',
	imageUploadUrl: 'http://localhost/CKFinderJava/ckfinder/core/connector/java/connector.java?command=QuickUpload&type=Images&responseType=json'		     
} );

Next I have D&D image, it has been uploaded and notification was displayed.

Have I missed anything?

If you have done exactly the same and you get errors, could your try clearing your cache (not Ctrl+F5 which only refreshes the cache) accoring to http://www.wikihow.com/Clear-Your-Browser's-Cache and re-check

comment:4 Changed 3 years ago by Adam De Lay

I found the problem. The page I was updating had a hidden editor that's set to display source mode by default and the UploadImage plugin was complaining because I removed the plugin for the toolbar to hide the display.

Thanks for your help.

comment:5 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thank you for the feeback.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy