Opened 4 years ago

Closed 4 years ago

#14281 closed Bug (duplicate)

webkit: strong turns into b after deletion

Reported by: Sergiy Kuzmenko Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

^ represents caret position:

  1. Make a text bold. The resulting markup will be something like <strong>a</strong>^.
  2. Press backspace/delete. Markup becomes ^ (strong node gets deleted).
  3. Type something. Markup becomes <b>a</b>.

Expected result

I would expect one of the following:

  1. strong rather than b (since this is the default markup).
  2. no formatting (since b node was removed).

Actual result

strong gets replaced with b.

Other details (browser, OS, CKEditor version, installed plugins)

Webkit browsers on OSX.

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.4

After some checking it has turned out this is a duplicate of #13224.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy