Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14283 closed Bug (invalid)

Leaflet Maps: not found in CKEditor Builder page

Reported by: Ranel Padon Owned by:
Priority: Normal Milestone:
Component: Project : CKBuilder Version:
Keywords: Cc:

Description

I'm the developer of Leaflet Maps and Prism Syntax Highlighter. I wanted to implement new features to my Leaflet Maps plugin so I tried first downloading a custom CKEditor build with it, but for some reason, Leaflet Maps is not in the list of available plugins that could be included in the build.

Steps to reproduce

  1. Go to CKEditor Builder page.
  2. In the Choose preset section, choose 'any' preset .
  3. In the Select your plugins and skin section, scroll/search for Leaflet Maps plugin.

Expected result

The Leaflet Maps plugin should be there since even my new plugin I've just released today Prism Syntax Highlighter is also there.

Actual result

The Leaflet Maps plugin could not be found, even when I searched for it (using the inline search icon) in the Select your plugins and skin section. See attached files also.

Other details (browser, OS, CKEditor version, installed plugins)

Chrome, Mac OSX, and trying to auto-build the CKEditor 4.5.6 with Leaflet Maps.

PS

I'm thinking that there might be a bug in the website/CKBuilder page and maybe other plugins are also affected. Likewise, this issue happens both when I'm an authenticated user or as an anonymous user in ckeditor.com

Attachments (2)

pic1.png (363.4 KB) - added by Ranel Padon 3 years ago.
pic2.png (180.2 KB) - added by Ranel Padon 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by Ranel Padon

Attachment: pic1.png added

Changed 3 years ago by Ranel Padon

Attachment: pic2.png added

comment:1 Changed 3 years ago by Ranel Padon

I've figured out the root cause and fix for my issue. I've realized that the CKEditor auto-build is set with CKEditor 4.5.6 and my plugin for some reason indicated that it has no support for 4.5.x (when I checked the version releases in Leaflet Maps plugin page). Yet, my plugin still works as intended for 4.5.x version, so I uploaded a new release and indicated that it's compatible with 4.5 version. After that, Leaflet Maps is now showing in CKEditor Builder page.

It might be good if there's some texts in plugin's page release history section that will indicate that the CKEditor version support will have implication in the auto-build behavior.

I think we could mark this bug as closed/fixed. Cheers. :)

comment:2 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed

comment:3 Changed 3 years ago by Jakub Ś

Keywords: autobuild search leaflet removed
Version: 4.5.6
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy