Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14298 closed Bug (invalid)

CKEditor treats button element as resizable image in IE11

Reported by: Mike Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.6
Keywords: ie11, button, image Cc:

Description

When using CKEditor and IE11, a <button> element inside the CKEditor's contents is displayed in a way that button appears to be a resizable image. In fact, the handles can be dragged to resize the button. This behavior does not occur in Firefox or Chrome. This behavior complicates editing because multiple clicks are required when I want to edit the button's text in WYSIWYG mode.

Steps to reproduce

  1. Use any CKEditor build with IE1
  2. Set an editor instance's contents to "<button>Button</button>".
  3. Click, double-click, and triple-click the button to see that the button will be outlines with dragging handles.

Expected result

The button should appear as a typical button that is not resizable and does not require multiple clicks to focus on the editable text of the button.

Actual result

The button shows resizing handles and outlines the button as if it were an image.

Other details (browser, OS, CKEditor version, installed plugins)

  1. This only happens in IE11.
  2. Windows 7
  3. CKEditor v4.5.6
  4. Plugins: any combination of installed plugins; removing all standard plugins with removePlugins option will not fix this behavior

Attachments (2)

ie_button.png (34.3 KB) - added by Mike 3 years ago.
IE11 button example
chrome_button.png (48.4 KB) - added by Mike 3 years ago.
Chrome Button example

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by Mike

Attachment: ie_button.png added

IE11 button example

Changed 3 years ago by Mike

Attachment: chrome_button.png added

Chrome Button example

comment:1 Changed 3 years ago by kkrzton

Status: newconfirmed

I was able to reproduce this issue using Button dialog on IE11 and Windows 10 with CKEditor 4.5.6.

comment:2 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7

comment:3 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:4 Changed 3 years ago by kkrzton

Owner: kkrzton deleted
Status: assignedconfirmed

There were similar issues caused by the same problem in the past: #9317 (and all related).

It is much wider issue concerning many elements and for now it has not been solved for IE11 (#12772#comment1). The cause is in native implementation and there were some fixes for MS Edge but not IE11 (https://connect.microsoft.com/IE/feedback/details/907422/ie11-unable-to-disable-resize-helper-for-images-inputs-etc-inside-contenteditable, https://connect.microsoft.com/IE/feedback/details/742593/please-respect-execcommand-enableobjectresizing-in-contenteditable-elements).

There is also a very comprehensive description of this issue on SO by Reinmar.

comment:5 Changed 3 years ago by Marek Lewandowski

Resolution: invalid
Status: confirmedclosed

True, there's nothing we can do about it in IE11 as Microsoft team does not want to fix this issue. They only allege it's fixed for Edge.

comment:6 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.7
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy