Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14314 closed Bug (fixed)

Selecting text within editor using Safari on page with multiple ckeditor instances results in odd scrolling behavior.

Reported by: Eric Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.4
Keywords: Safari Mac Cc:

Description

Steps to reproduce

  1. Load a web page in Safari 9.0.2 with multiple CKEditor instances where the text length exceeds the editor height.
  2. Try to highlight/select text with mouse in one of the editors.

Expected result

Be able to highlight/select text using mouse without issue.

Actual result

Entire browser window scrolls all the way to the bottom.

Other details (browser, OS, CKEditor version, installed plugins)

Browser: Safari 9.0.2, CKEditor Version: 4.5.4 Full, OS: Mac OSX 10.10.5

Note: I was able to reproduce the bug on the demo pages with multiple CKEditor instances at ckeditor.com/demo.

Change History (16)

comment:1 Changed 3 years ago by mattdyer

I am seeing the same issue with scrolling. I only have one ckeditor on the page. I only see the problem in Safari Version 9.0.2 (11601.3.9). I am on Mac OS 10.11.12. We currently have ckeditor 4.4.3, but I will be testing out the latest version to see if it helps.

Edit: My Safari was auto updated to 9.0.3 today. I tested again on the ckeditor demo page with the full featured editor. The scrolling seems a little slower, but still as soon as I start selecting text it scrolls the main window down very quickly.

Last edited 3 years ago by mattdyer (previous) (diff)

comment:2 Changed 3 years ago by mattdyer

I updated my ckeditor to 4.5.6 and tested again. I am using Safari 9.0.3 on Max OS 10.11.3. I am still seeing the scrolling issue. The whole window scrolls down when you try to select text. I makes it almost impossible to select just the text that you want.

comment:3 Changed 3 years ago by Brad

I have reproduced it on my Mac with Yosemite 10.10.5 and Safari 9.0.3. It is only when highlighting text in CKEditor. It seems to scroll the entire page when you click and drag for highlighting. The CKEditor demo site also exhibits this broken behavior.

TEMPORARY SOLUTIONS: Double clicking for highlighting and holding shift and navigating via the arrow keys work just fine for highlighting text. Other browsers (Chrome, Firefox) in Yosemite 10.10.5 work correctly.

comment:4 Changed 3 years ago by design_ev

I am also experiencing this problem. Running OS 10.10.5, Safari 9.0.2 and I've experimented with the most recent as well as other recent releases of CKEditor and all produce this page scrolling bug. The page essentially "runs away on you" while trying to select text. I've advised users at our organization to use Chrome for the time being as the problem does not exist on this browser.

comment:5 Changed 3 years ago by Jakub Ś

Keywords: Safari MAC added
Status: newconfirmed

I haven't seen this issue in Safari 9.0 but after upgrading to Safari 9.0.3 scrolling occurs. It really makes editor unusable.

Please see: http://ckeditor.com/demo#acf

comment:6 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8

comment:7 Changed 3 years ago by Marek Lewandowski

Couldn't repro with Safari 9.0

comment:8 Changed 3 years ago by Jakub Ś

Keywords: Mac added; MAC removed

comment:9 Changed 3 years ago by Jakub Ś

The problem has two culprits IMO and both consider page scrolling.

  1. When you focus the editor, page scrolls down so that the editor is in the centre of the view port (at least this is the goal IMO).
  2. Whenever you select text in editor with a mouse, drag the mouse down and leave editor with cursor then the moment whole text in editor is selected, whole page starts to scroll down. To see this you need of course scrollbars in both - CKEditor and page.

What we are seeing here is the mixture of the above two. When you click inside editor (and still hold mouse button), whole page scrolls down to centre the CKEditor. The cursor ends up below the editor, text is being selected and once this is done whole page scrolls down.

comment:10 Changed 3 years ago by Marek Lewandowski

Checked with Safari 9.0.3 and I can reproduce it. It seems that's a regression of Safari 9.0.3. Let us see if we can do something about it.

comment:11 Changed 3 years ago by Marek Lewandowski

Yup, in fact it is a recent Safari regression, I've created a simplified demo where you can attempt to select the text. We've sent a bug report to Apple - there might be little we can do about it, still we'll check it.

TC:

  1. Open an example attached here: https://jsfiddle.net/fpua774e/
  2. Try to select part of the "Try to select some text" text (just simply click and move mouse horizontally)

Expected: Selection is properly created for the text from the anchor point to your cursor position.

Actual: Scrolling goes wild, and scrolls both inner and outer window. It shouldn't do that in a first place, since we're only selecting horizontally, so vertical scrolling should not be involved.

Last edited 3 years ago by Marek Lewandowski (previous) (diff)

comment:12 Changed 3 years ago by Marek Lewandowski

And here is a reference to WebKit bugzilla #153872 issue.

Last edited 3 years ago by Marek Lewandowski (previous) (diff)

comment:13 Changed 3 years ago by Sheldon

This seems to have been fixed by Apple. It appears that it was appearing in other editors besides CKEditor as well: http://forums.macrumors.com/threads/safari-scrolls-down-on-edit-issue.1961579

I updated my Mac to the latest MacOS (10.11.4) release and the scrolling issue hasn't happened since.

comment:14 Changed 3 years ago by Jakub Ś

I can confirm that. I have checked Safari 9.1 on MAC 10.11.4 and issue seems to be working fine now.

comment:15 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: confirmedclosed

Great, thanks!

comment:16 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.8
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy