Opened 4 years ago

Closed 4 years ago

#14326 closed Bug (invalid)

The Text not retaining the Tabs while pasting the content in Text Editor

Reported by: Thiruvenkata Subramanian Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. copy the text which i given below
  2. paste in Text editor
  3. Tabs not retaining

Test data:

1tab

2tab

3tab

3tab

2tab

1tab

Expected result

Tabs has to be retained

Actual result

Not retaining

Other details (browser, OS, CKEditor version, installed plugins)

Attachments (1)

TabIssue.jpg (80.4 KB) - added by Thiruvenkata Subramanian 4 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by Thiruvenkata Subramanian

Browser Used is IE11

comment:2 Changed 4 years ago by Jakub Ś

Status: newpending
Version: 4.5.3

I can't confirm this issue.

If this is happening with text pasted from Notepad then this is how such text is seen by browser: tab0<br>&nbsp;tab1<br>&nbsp;&nbsp;tab2<br>&nbsp;tab1<br>tab0 Consecutive white spaces are pasted as one.

If this is happening when copying HTML from website then assuming that tabs are made with margin-left, please make sure that ACF is configured correctly.


Where is that tabbed text copied from? Please attach sample file. Please also provide a screen cast showing how to reproduce this problem in CKEditor demo.

Changed 4 years ago by Thiruvenkata Subramanian

Attachment: TabIssue.jpg added

comment:3 Changed 4 years ago by Thiruvenkata Subramanian

The text has been copied from Notepad. Please refer the attachment.

comment:4 Changed 4 years ago by Jakub Ś

Resolution: invalid
Status: pendingclosed

Thank you for the clarification. Unfortunatelly there is nothing we can do here.

This is broswer sees it ans since CKEditor gest data processed by a brwoser there is no workaround we can provide. This is what IE11 sees (nad this is what CKEditor pastes):

&nbsp;tab1<br>&nbsp;&nbsp;tab2<br>&nbsp;&nbsp;&nbsp;tab3<br>&nbsp;&nbsp;tab2<br>&nbsp;tab1
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy