Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#14345 closed Bug (invalid)

AVT: FF-Keyboard Navigation between Toolbar groups not working properly

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version: 4.5.6
Keywords: ibm Cc: chrisgui, Irina

Description

Steps to reproduce

  1. Open nightly build http://nightly.ckeditor.com/16-01-25-07-07/full/samples/
  2. Navigate to editor body & press Alt + F10 to access toolbar
  3. Focus goes to first toolbar group.
  4. Press TAB key

Expected result

Focus goes to next toolbar group and focus should saty in toolbar until user press ESC to navigate to editor body

Actual result

Focus going to editor body. when user tried again, this time after second TAB focus going to editor body

Only happening in Firefox & it works properly in IE, Chrome. Tested on FF 43.0.4

Change History (10)

comment:1 Changed 3 years ago by kkrzton

Status: newpending

Tested in FF 43.0.4 on Ubuntu 14.04 LTS and Win7 and works as expected in both environments. Used mouse and then keyboard (tab, tab+shift) to focus on editor body, in all cases works as expected.

Can you provide more information about operating system and maybe there are some add-ons installed in FF?

comment:2 in reply to:  1 ; Changed 3 years ago by Satya Minnekanti

Replying to k.krzton:

Tested in FF 43.0.4 on Ubuntu 14.04 LTS and Win7 and works as expected in both environments. Used mouse and then keyboard (tab, tab+shift) to focus on editor body, in all cases works as expected.

Can you provide more information about operating system and maybe there are some add-ons installed in FF?

@k.krzton Please read defect summary & description before commenting. I'm talking about issues with TAB key Navigation in toolbar groups(Notfocusing in & out of editor body) I clearly mentioned what's expected & what's actually happening. Once you navigated to first group in Toolbar by pressing ALT + F10 from editor body & subsequent TAB key press should navigate between toolbar groups. Focus should not come out of editor toolbar. Focus should go to editor body onely when user press ESC. Please see IE/CHROME for correct behaviour.

Please re-open the defect & it's a SEV 1 defect for IBM

Last edited 3 years ago by Satya Minnekanti (previous) (diff)

comment:3 in reply to:  2 Changed 3 years ago by kkrzton

Replying to satya:

I didn't make my description clear enough, sorry for that. What I meant here:

Used mouse and then keyboard (tab, tab+shift) to focus on editor body, in all cases works as expected.

refers only to point:

  1. Navigate to editor body

which means I tried different methods for navigating to editor body. Apart from that all steps where reproduced same as you described and I still was not able to reproduce the issue. This means that after focusing in first group in Toolbar by pressing ALT + F10, subsequent TAB key press navigates between toolbar groups and focus goes to editor only after pressing ESC. I also compared this behavior with Chrome and it is same in both browsers.

I did not close the issue so it can be investigate further. Providing additional information which I asked earlier could be helpful.

comment:4 Changed 3 years ago by Jakub Ś

Status: pendingconfirmed

I was able to confirm this issue even in CKEditor 3.x so this looks like Firefox regression.

I'm using Win 7 and FF 43.0.4.

Last edited 3 years ago by Jakub Ś (previous) (diff)

comment:5 in reply to:  4 Changed 3 years ago by Satya Minnekanti

Replying to j.swiderski:

I was able to confirm this issue even in CKEditor 3.x so this looks like Firefox regression.

@j.swiderski Thanks for confirming it. yes it definitely is a Firefox regression, But we need to confirm it & if you think it's firefox defect it has to be logged with firefox or CK has to fix it if firefox changed something recently.

comment:6 Changed 3 years ago by Marek Lewandowski

I can't repro it with the exact same setup as @j.swiderski so I went with checking on multiple combinations and tested three different setups:

  • Win7 + FF 43.0.4 - can't repro
  • Win7 + FF 47.0a1 (nightly version) - can't repro
  • Win8.1 + FF 43.0.4 - can't repro

All combinations were tested on mentioned nightly build.

@satya @j.swiderski Is there a chance that you guys have some extensions or anything else affecting FF?

Last edited 3 years ago by Marek Lewandowski (previous) (diff)

comment:7 Changed 3 years ago by Jakub Ś

I have just the Firebug.

One note - I have cleared cache (Ctrl+F5 has given me same result) and with every new Alt+F10 Tab I could go to one group further until I could reach all of them. Really weird.

comment:8 Changed 3 years ago by Jakub Ś

Status: confirmedpending

After some testing I have discovered that this issue is happening only when Firebug is opened.

When tabbing with Firebug closed or even with native Firefox WWW console (Ctrl+Shift+K) everything works as expected (it was enough for me to refresh page with Ctrl+F5 before every setup). It looks like Firebug is breaking the Tab order.

@satya could you recheck and let me know your results?

comment:9 in reply to:  8 Changed 3 years ago by Satya Minnekanti

Replying to j.swiderski:

After some testing I have discovered that this issue is happening only when Firebug is opened.

When tabbing with Firebug closed or even with native Firefox WWW console (Ctrl+Shift+K) everything works as expected (it was enough for me to refresh page with Ctrl+F5 before every setup). It looks like Firebug is breaking the Tab order.

@satya could you recheck and let me know your results?

@j.swiderski This issue is not happening when i de-activate firebug, so we can close it as firbug issue.

comment:10 Changed 3 years ago by Marek Lewandowski

Resolution: invalid
Status: pendingclosed

Thanks for confirming that Satya!

Last edited 3 years ago by Marek Lewandowski (previous) (diff)
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy