Opened 4 years ago

Closed 4 years ago

#14352 closed Bug (invalid)

Browser Edge (windows 10) - after a "CTRL + ENTER" in the CK Editor the keyboard up/down doesn't work anymore

Reported by: Harm Tester Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

Go to the demo of CKEditor in browser Edge (25.10586.0.0) on Windows 10

  1. Type some text
  2. click CTRL+ENTER
  3. Type some text
  4. click on the keyboard arrows up or down

Expected result

When clicking up the cursor goes up and when clicking down the cursor goes down.

Actual result

After clicking the up button the cursor goes to the begin of the paragraph and clicking down the cursor goes to the end of the paragraph

Other details (browser, OS, CKEditor version, installed plugins)

This behavior is standard available on the CKEditor ENTER Ker >> "Produce <br> on ENTER" on the demo page http://ckeditor.com/demo#enter

Attachments (1)

Change History (3)

Changed 4 years ago by Harm Tester

comment:1 Changed 4 years ago by kkrzton

Status: newconfirmed

After some testing I found the following:

In all browsers but IE (checked on Edge and IE11, IE9): When pressing up/down key while inside one line long text, cursor goes to beginning/end of the paragraph/line. While inside multiple line long text, cursor goes up/down unless it is first/last line. When in first/last line it goes to the beginning/end of this line.

In Edge/IE: pressing up/down moves cursor up/down as expected, but does not move it to the beginning/end of the line as in other browsers. CTRL+ENTER does not seem to change this behavior.

So it seems the problem is in moving cursor to the beginning/end of the line with up/down keys.

Using Edge 20.10240.16384.0 on Win10.

comment:2 Changed 4 years ago by Jakub Ś

Keywords: browser Edge arrow up down windows10 removed
Resolution: invalid
Status: confirmedclosed
Version: 4.5.6

After clicking the up button the cursor goes to the begin of the paragraph and clicking down the cursor goes to the end of the paragraph

I have checked this issue in Chrome and IE. While in IE I have not found it (just like @k.krzton has described it), I have found it in e.g. Chrome. The problem is that the same thing is happening in native contenteditable element (This is how browser handles it).
Taking the above into account we cannot consider this a CKEditor issue.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy