Opened 10 years ago

Closed 10 years ago

#1436 closed Bug (fixed)

Safari : Sub-menus panels are not being hidden

Reported by: Frederico Caldeira Knabben Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: UI : Context Menu Version: FCKeditor 2.5 Beta
Keywords: Confirmed Cc:

Description

When using sub-menus in the context menu, like table operations, when choosing one of the sub-menu options, its panel is not being hidden and remains visible. It's enough to click in the editing area to hide it.

Attachments (1)

fckeditingarea.js (11.0 KB) - added by Jeff Johnson 10 years ago.
Change FCKEditingArea.prototype.Focus behavior for Safari

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Jeff Johnson

Attachment: fckeditingarea.js added

Change FCKEditingArea.prototype.Focus behavior for Safari

comment:1 Changed 10 years ago by Jeff Johnson

If I change:

this.IFrame.focus();

to:

this.Window.focus();

Under the FCKEditingArea.prototype.Focus definition, that seems to fix it. Are there ramifications in doing so?

comment:2 Changed 10 years ago by Frederico Caldeira Knabben

Resolution: fixed
Status: newclosed

Fixed with #1095.

We were previously using the IFrame.focus() call for Safari only, because that was the only way to make it work on it. It seams the window.focus() has been fixed at Apple's side, so we can now live without the hack.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy