Opened 3 years ago

Closed 3 years ago

#14437 closed Bug (invalid)

Error in Safari: this.$.document is undefined (evaluating doc.compatMode)

Reported by: Johannes Spohr Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Our ErrorReporting tool reports a lot of errors of this kind, which seem to occur only in Safari after working the editor for a while. The problem seems to be that in the lineUtils Plugin Line 328 this.win.getViewPaneSize() is called, and in dom/window.js on line 51 doc is not defined.

Exact error message is: TypeError: undefined is not an object (evaluating 'a.compatMode')
1 File "(unknown)" line (unknown) in getViewPaneSize
2 File ..ckeditor/plugins/lineutils/plugin.js line 21 col 185 in queryViewport

We're using 4.5.7 and it only occurs in Safari on Mac.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.7

In order to accept a bug report, we need exact steps to reproduce it.

Please also note that you should be able to reproduce this issue with default CKEditor not integrated into your application as otherwise this problem might be caused by third-party script or some other third-party CKEditor plugin or CKEditor core code modification.

I'm closing this ticket as invalid for now. Once it gets updated, I will reopen it if there really is a problem with the editor.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy