Opened 3 years ago

Closed 3 years ago

#14453 closed Bug (invalid)

HTML form in edited text destroys the CKEditor form

Reported by: Ingo Hamann Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

Steps to reproduce

  1. define a html form in CKEditor source mode
  2. save the edited text with the contained HTML form
  3. open the website with embedded CKEditor again

Expected result

In source mode: The HTML source code including the complete source code of the form should be visible inside the CKEditor "window" (form textarea). In render mode: The contained form should be displayed like on a website.

Actual result

The forms within the edited text and the surrounding CKEditor form are both interpreted by browser as active elements - and the result is undefined.

Other details (browser, OS, CKEditor version, installed plugins)

CKEditor 4.5.6 embedded in Shop software Gambio GX2 v2.7.1.2 Browser: Firefox 44.0.2

In older versions of (Gambio + CKEditor) did it work, if we wrote a HTML form into CKEditor window. It was correct interpreted and displayed on the website and if the sourcecode was opened in CKEditor again, it was correct diplayed and stayed editable.

This behavior is now destroyed ... but we have many forms in our Gambio shop integrated. They all are not longer editable.

We had contact with Gambio in this issue but they said the mistake is in the newer CKEditor version.

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.7

save the edited text with the contained HTML form

CKEditor is JavaScript application and has nothing to do with saving data. If you can't reproduce this problem by simply switching to source mode and back then you need to check your server-side code.

I'm closing this issue as invalid for now. Could you tell me if Gambio has given you any details why this is CKEditor issue and if you are able to reproduce this problem in CKEditor without saving data (without server-side)?

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy