Opened 12 years ago

Closed 12 years ago

#1452 closed Bug (worksforme)

Style Dropdowns are translucent

Reported by: bhakti Owned by:
Priority: Normal Milestone: Safari Compatibility
Component: General Version: FCKeditor 2.5 Beta
Keywords: Pending WorksForMe Cc:

Description

The Style, Format and Font Dropdowns are transparent and hence you can see the content of the Editor in the background. Attached an image

Attachments (2)

Translucent.JPG (74.5 KB) - added by bhakti 12 years ago.
ScreenShot
NonTranslucent.png (77.0 KB) - added by Frederico Caldeira Knabben 12 years ago.
Screenshot on Safari 3.0.3 (522.12.1) / Mac OS X 10.4.10

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by bhakti

Attachment: Translucent.JPG added

ScreenShot

Changed 12 years ago by Frederico Caldeira Knabben

Attachment: NonTranslucent.png added

Screenshot on Safari 3.0.3 (522.12.1) / Mac OS X 10.4.10

comment:1 Changed 12 years ago by Frederico Caldeira Knabben

Keywords: Pending WorksForMe added

I've attached a screenshot of what I have here instead. It was taken from a Mac, but I have the same results over Windows.

But, as they say, "a picture worth more than a thousand words", and your screenshot shows it. So, let's try to investigate the reason.

Do you think you can attach the HTML of your "richtext01.cfm" page? I mean the HTML sent to the browser, not the server side code. It could help us identifying any external element that could be breaking things.

Also, do you have changed the default CSS files released with the editor? There could be something there that is breaking it.

comment:2 Changed 12 years ago by Frederico Caldeira Knabben

Updates on this... it seams that CSS changes could really cause this. I was able to reproduce it by removing the "background-color: #ffffff;" from the "editor/css/fck_editorarea.css" and "editor/skins/default/fck_editor.css" files.

Can you confirm that this is your case, bhakti?

Those CSS definitions are really needed. The editor is broken without them.

comment:3 Changed 12 years ago by Frederico Caldeira Knabben

Milestone: FCKeditor 3.0Safari Compatibility

comment:4 in reply to:  3 Changed 12 years ago by bhakti

Replying to fredck: I think there was some problem with the Global styles after setting the Global styles, this is not reproducible. Can close this ticket

comment:5 Changed 12 years ago by Frederico Caldeira Knabben

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy