Opened 3 years ago

Closed 3 years ago

#14538 closed Bug (fixed)

Keyboard focus goes into embedded iframe element

Reported by: Satya Minnekanti Owned by: Tomasz Jakut
Priority: Normal Milestone: CKEditor 4.5.9
Component: Accessibility Version: 4.5.0
Keywords: IBM Cc: chrisgui, Irina

Description (last modified by Jakub Ś)

Steps to reproduce

  1. Open Media embed sample http://sdk.ckeditor.com/samples/mediaembed.html
  2. Delete existing data & add few paragraphs of text
  3. Embed a video using folowing URL https://vimeo.com/86541796
  4. Video embedded and focus is on video.
  5. Press Right arrow ke to focus back to editor body.
  6. Press TAB key

Expected result

Focus goes out of editor body and focs on next focusable element out of editor

Actual result

Focus goes to controls inside video and JAWS reading all controls but user can't play it. Same thing happens when user Shift + TAB back in to editor body. This is Accessibility Violation

The Video controls should not be Accessible at all since user can't play video with mouse or keyboard & TAB key is used to navigate in & out of editor

Change History (6)

comment:1 Changed 3 years ago by Jakub Ś

Status: newconfirmed
Version: 4.5.74.5.0

I think invalid link was attached in point three but I can confirm this ticket.

I have attached default youtube link from sdk sample and Right Arrow + Tab has really moved focus back to widget. Next tab has moved focus to youtube video control (play button) and finally third focus has moved focus out of editor.

comment:2 Changed 3 years ago by Jakub Ś

Description: modified (diff)

comment:3 Changed 3 years ago by Tomasz Jakut

Owner: set to Tomasz Jakut
Status: confirmedreview

The problem seems to be caused by native browsers' behavior: they put iframes into page's focus list and allows to navigate inside the iframe. Adding [tabindex=-1] to the iframe prevents that default behavior (as it removes the iframe from page's focus list).

I've added simple regex to the JSONp callback that finds iframe opening tag and adds [tabindex] attribute to it.

Pushed fix to branch:t/14538.

comment:4 Changed 3 years ago by Marek Lewandowski

Summary: AVT: Focus going to controls in video that user can't playKeyboard focus goes into embedded iframe element

comment:5 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9

comment:6 Changed 3 years ago by Marek Lewandowski

Resolution: fixed
Status: reviewclosed

Proposed solution is enough to fix the problem, actually all we want to do is to remove fetched iframes from the focus list in our cE.

Fixed with git:71e7ca7, merged to master.

Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy