Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#14554 closed Bug (duplicate)

IE/EDGE: Font Name dropdown not showing font styles of text copied from word doc

Reported by: Satya Minnekanti Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: IBM Cc: chrisgui, Irina

Description

Steps to reproduce

  1. Open nightly build
  2. Copy text from attached word doc where each paragraph has diff font names applied
  3. Open Paste from Word dialog , paste content from clipboard & click OK button.
  4. Content pasted with all formatting kept.
  5. Keep cursor in each of the paragraphs

Expected result

Font Name drop down should reflect font of orresponding paragraph

Actual result

No Font shown in Font Name dropdown

Attachments (1)

text with diff font names.doc (22.0 KB) - added by Satya Minnekanti 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by Satya Minnekanti

comment:1 Changed 6 years ago by Jakub Ś

Resolution: duplicate
Status: newclosed
Version: 4.5.7

This issue is in fact a duplicate of #9964.

  1. I was very surprised to see that pasting from your word document doesn't work at all in Firefox and Chrome. I will, need to investigate this and update this post.
  1. Let's focus on IE/EDGE where pasting works. The code that gets pasted is:
    <p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Times New Roman&quot;,&quot;serif&quot;; font-size: 18pt;"><font color="#000000">Apple is good for health</font></span></p>
    
    <p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Georgia&quot;,&quot;serif&quot;; font-size: 28pt;"><font color="#000000">Banana is good for athletes for quick energy</font></span></p>
    
    <p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Comic Sans MS&quot;; font-size: 14pt;"><font color="#000000">Carrot is good source of vitamin A</font></span></p>
    
    

Now, from what I have checked the middle line works but rest don't. Why is that? If you look how styling in CKEditor currently works and at the fot names definitions, you will know that any style in order to be reflected in dropdown has to match it exactly. It has to be 1:1 match.
There is Georgia, serif in font definitions and the same in middle paragraph so there is a match. The other two don't match but if you alter third line to Comic Sans MS, cursive; you will notice that it works too. Please try code below:

<p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Times New Roman&quot;,&quot;serif&quot;; font-size: 18pt;"><font color="#000000">Apple is good for health</font></span></p>

<p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Georgia&quot;,&quot;serif&quot;; font-size: 28pt;"><font color="#000000">Banana is good for athletes for quick energy</font></span></p>

<p style="margin: 0cm 0cm 8pt;"><span lang="EN-IE" style="line-height: 107%; font-family: &quot;Comic Sans MS&quot;,&quot;cursive&quot;; font-size: 14pt;"><font color="#000000">Carrot is good source of vitamin A</font></span></p>

I'm closing this ticket as a duplicate because I think it is covered by #9964 fully. If you don't agree, please leave a comment. As for pasting in Chrome and FF, I will need to make further research.

Version 0, edited 6 years ago by Jakub Ś (next)
Note: See TracTickets for help on using tickets.
© 2003 – 2021 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy