Opened 4 years ago

Closed 3 years ago

#14570 closed Bug (fixed)

EDGE: Widget selection lost when dialog closed

Reported by: Satya Minnekanti Owned by: Tomasz Jakut
Priority: Normal Milestone:
Component: General Version: 4.5.9
Keywords: IBM Cc: Irina, chrisgui

Description

Steps to reproduce

  1. Open Media Embed sample http://sdk.ckeditor.com/samples/mediaembed.html
  2. Delete existing content, add few paragraphs of text
  3. Embed a video in between paragraphs by using Media Embed dialog
  4. Double click on video to open Media Embed dialog
  5. Press ESC or click on Cancel button

Expected result

Media Embed dialog closed & focus goes to video & video is selected

Actual result

Media Embed dialog closed but focus goes out of video & cursor is placed at end of last paragraph

Change History (9)

comment:1 Changed 4 years ago by kkrzton

I tried to reproduce this issue using EDGE version 20.10240.16384.0 on Windows 10 but without success.

The thing is AFAIR (14543#comment:2) @satya is using EDGE version 25.10586.0.0. so we should also checked with this newer version.

@satya we will keep you updated on this one.

comment:2 Changed 4 years ago by kkrzton

Status: newconfirmed

I can confirm that on newer version of EDGE (25.10586.0.0) I can reproduce the issue.

comment:3 Changed 4 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:4 Changed 4 years ago by Tomasz Jakut

Owner: changed from kkrzton to Tomasz Jakut

comment:5 Changed 3 years ago by Tomasz Jakut

Status: assignedreview

Pushed proposal of fix to branch:t/14570.

It's however worth noting that in newer version of Edge (34) which is available in Win 10 preview, everything seems to be working fine without the fix.

comment:6 in reply to:  5 ; Changed 3 years ago by Satya Minnekanti

Replying to t.jakut:

Pushed proposal of fix to branch:t/14570.

It's however worth noting that in newer version of Edge (34) which is available in Win 10 preview, everything seems to be working fine without the fix.

Thx for comment. Version of EDGE you mentioned still not released to end users(only preview) & we don't know when it will be available. we need this fix ASAP so IBM request you to deliver the fix

comment:8 in reply to:  6 Changed 3 years ago by Marek Lewandowski

Status: reviewpending

Replying to satya:

Replying to t.jakut:

Pushed proposal of fix to branch:t/14570.

It's however worth noting that in newer version of Edge (34) which is available in Win 10 preview, everything seems to be working fine without the fix.

Thx for comment. Version of EDGE you mentioned still not released to end users(only preview) & we don't know when it will be available. we need this fix ASAP so IBM request you to deliver the fix

Since this is an Edge bug, and it has been fixed in upcoming Edge release, it's best for us to wait for the update to go live.

I'd expect it to happen with upcoming Windows anniversary update.

comment:9 Changed 3 years ago by Jakub Ś

Resolution: fixed
Status: pendingclosed

It works as expected in Edge 38.14393.0.0

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy