Opened 3 years ago

Closed 2 years ago

#14573 closed Bug (fixed)

Multiple editors, drag handler icon and divarea, missing CSS

Reported by: AlexW Owned by: kkrzton
Priority: Normal Milestone: CKEditor 4.5.9
Component: UI : Widgets Version: 4.3
Keywords: Cc:

Description

An example can be seen here, https://jsfiddle.net/ew490f12/1/ Hover over the widget in the second editor.

If you have two editors using divarea with the second using the enhanced image plugin the drag handle seems to be missing CSS so the image is full width and repeated.

Change History (6)

comment:1 Changed 3 years ago by Jakub Ś

Status: newconfirmed
Version: 4.5.84.3

Problem can be reproduced from at least CKEditor 4.3.

comment:2 Changed 3 years ago by Marek Lewandowski

Milestone: CKEditor 4.5.9

comment:3 Changed 3 years ago by kkrzton

Owner: set to kkrzton
Status: confirmedassigned

comment:4 Changed 3 years ago by kkrzton

Status: assignedreview

Changes in t/14573.

The issue was caused by the fact that CKEditor adds inline stylesheet to the DOM and the code does not overwrite it if styles changes (many instances and one adds some styles after the stylesheet were appended to the DOM already - the exact case which causes above issue). The solution is to check if styles have changed and update already appended stylesheet accordingly.

comment:5 Changed 2 years ago by Tade0

Status: reviewreview_passed

The fix works fine, the tests are passing, I believe this solution should do.

Side note: I see that you fixed that code style problem that keeps popping up recently. I'm having some mixed feelings about the style of the fix, but then again it's doing much less damage readability-wise than my solution for the same problem.

Fixed with git:d8486d54ebaeffaa940a28f1a8b972047c345bc3, merged to master.

comment:6 Changed 2 years ago by Tade0

Resolution: fixed
Status: review_passedclosed
Note: See TracTickets for help on using tickets.
© 2003 – 2017 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy