Opened 4 years ago

Closed 3 years ago

#14582 closed New Feature (wontfix)

Unable to edit meta tags (microdata) within a widget

Reported by: AlexW Owned by:
Priority: Normal Milestone:
Component: General Version:
Keywords: Cc:

Description

I've got a widget that provides a template for creating a recipe. It has fields for preparation and cooking times with associated microdata meta tags.

<meta itemprop="prepTime" content="" />
<meta itemprop="cookTime" content="" />

I've got a keyup event that listens on the editables so the content attributes can be updated.

The problem is the meta tags are converted to comments which makes them difficult to update.

Could a way to manage these be added?

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.5.8

Unfortunately not.

Some time ago we have decided that meta tags in body element will be protected.
The only solution I could recommend here is that your widget goes through all the comments in document recognizes meta elements and updates their content attributes (decoding/encoding if necessary).

I assume you already know that but if you are using ACF you need to allow meta tags in CKEditor or better widget configuration e.g.

var editor = CKEDITOR.replace( 'editor1', {
	extraAllowedContent : 'meta[*]{*}(*)'
});
Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy