Opened 3 years ago

Closed 3 years ago

#14589 closed Bug (invalid)

Editor removing <div> style

Reported by: Mick O'Rourke Owned by:
Priority: Normal Milestone:
Component: Performance Version:
Keywords: Cc: mick@…

Description

If I enter my own style such as <div class="col_1"> Column One</div> when the editor saves the page the div gets transformed to <div>Column One</div> class or id gets removed .

Steps to reproduce

Expected result

Actual result

Other details (browser, FIRE FOX 45.0.2 / Chrome 49.0.2623.112 m

OS, Windows

CKEditor version, 4.5.8 installed plugins) ==

Change History (1)

comment:1 Changed 3 years ago by Jakub Ś

Resolution: invalid
Status: newclosed
Version: 4.5.8
  1. Editor doesn't have anything to do with saving data as this is JavaScript application.
  2. If you are able to reproduce this issue in CKEditor when switching to source and back then this can be considered editor fault and is most likely caused by combination of ACF and plugins (allowed tags used in your editor).

To learn more about ACF, please see:
http://docs.ckeditor.com/#!/guide/dev_acf
http://docs.ckeditor.com/#!/guide/dev_advanced_content_filter
http://docs.ckeditor.com/#!/guide/dev_disallowed_content
http://docs.ckeditor.com/#!/api/CKEDITOR.filter-method-addTransformations
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-allowedContent
http://docs.ckeditor.com/#!/api/CKEDITOR.config-cfg-extraAllowedContent

You could try below to allow everything for divs in CKEditor.

var editor = CKEDITOR.replace( 'editor1', {
extraAllowedContent : 'div{*}[*](*)'
});

@mick104 I'm closing this ticket because I think it is invalid but if this is not what you are having and you can reproduce this issue without saving and with proper ACF settings, please leave a comment.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy