Opened 4 years ago

Closed 4 years ago

#14596 closed Bug (wontfix)

Can't drag a widget between horizontal locations

Reported by: Matthew Popat Owned by:
Priority: Normal Milestone:
Component: UI : Widgets Version:
Keywords: Cc:

Description

Steps to reproduce

  1. Setup divs with style="display:inline-block" next to each other
  2. Create a draggable widget
  3. Try to drag the widget into the divs

Expected result

The drag line appears in the div that is closest to the cursor

Actual result

The drag line only ever appears in the left-most div

Change History (1)

comment:1 Changed 4 years ago by Jakub Ś

Resolution: wontfix
Status: newclosed
Version: 4.5.4

CKEditor determines what is block/inline element based on HTML specification. All this is written inside CKEditor.dtd.

You should not turn block elements into inline-block but rather use them in accordance with the spec.

NOTE: Please check out http://ckeditor.com/demo#widgets and image2 without caption and alignment. HTML is an image wrapped in inline-block span (please check it with dev-tools). This is something you could use for your widget and IMO it is much better to change inline element into inline-block instead of block into inline-block. Mainly because inline can be dragged between horizontal locations.

Note: See TracTickets for help on using tickets.
© 2003 – 2019 CKSource – Frederico Knabben. All rights reserved. | Terms of use | Privacy policy